Mis_APKBUILD/devil/APKBUILD
Victor Diego Alegandro Diaz Urbaneja 40fb56ca24 Añadiendo APKBUILD de devil
2019-07-17 01:56:57 -04:00

33 lines
892 B
Plaintext

# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
pkgname=devil
pkgver=1.8.0
pkgrel=0
pkgdesc="Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)"
url="http://openil.sourceforge.net/"
arch="x86_64"
license="GPL"
depends="libpng libmng"
makedepends="cmake"
subpackages="$pkgname-dev"
options="!check"
source="http://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz"
builddir="$srcdir/DevIL/DevIL"
build() {
cd "$builddir"
cmake CMakeLists.txt \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "$builddir"
DESTDIR="${pkgdir}" make install
install -Dm644 include/IL/ilut_config.h "${pkgdir}/usr/include/IL/"
}
sha512sums="103fa51f4094af0fe988bf9520e1b9178900f980b72226e64ede60b6b0938a646c670a37372214edb557e492947cd5af5012a3ac906734a5ea83e072f81db583 DevIL-1.8.0.tar.gz"