Mis_APKBUILD/fluidsynth/APKBUILD
Victor Diego Alegandro Diaz Urbaneja eed01282f6 Añadiendo APKBUILD de fluidsynth
2019-07-13 14:56:18 -04:00

35 lines
907 B
Plaintext

# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
pkgname=fluidsynth
pkgver=2.0.5
pkgrel=0
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
url="A real-time software synthesizer based on the SoundFont 2 specifications"
arch="x86_64"
license="LGPL"
depends=""
makedepends="cmake"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.zip::https://github.com/FluidSynth/$pkgname/archive/v$pkgver.zip"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
cmake CMakeLists.txt \
-DCMAKE_INSTALL_PREFIX=/usr \
-DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth \
make
}
check() {
cd "$builddir"
make -k check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="c3d7fc7692b25aee4fbfba8b53bb27a33911493e3cc20fc22c7b2cffa4d8bc71f8554008778f3afc88078482b637aead171f92687c81ba6ffadea807448fbf83 fluidsynth-2.0.5.zip"