You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
Kubernetes Publisher 4e3aa0457e Merge pull request #87179 from Jefftree/netproxy-uds 19 hours ago
.github delete all duplicate empty blanks 1 year ago
Godeps Merge pull request #87179 from Jefftree/netproxy-uds 7 hours ago
pkg Add tests for egress selector 1 week ago
plugin/pkg migrate authenticator and authorizer to Create 1 week ago
.import-restrictions move pkg/auth/user to staging 3 years ago
CONTRIBUTING.md Update deprecated links 1 year ago
LICENSE Add README and LICENSE to staging repos 2 years ago
OWNERS Add jpbetz as reviewer of api-machinery code 5 months ago
README.md delete all duplicate empty blanks 1 year ago
SECURITY_CONTACTS Update SECURITY_CONTACTS with current PSC 8 months ago
code-of-conduct.md Add code-of-conduct.md to staging repos 2 years ago
go.mod Merge pull request #87179 from Jefftree/netproxy-uds 7 hours ago
go.sum Merge pull request #87179 from Jefftree/netproxy-uds 7 hours ago

README.md

apiserver

Generic library for building a Kubernetes aggregated API server.

Purpose

This library contains code to create Kubernetes aggregation server complete with delegated authentication and authorization, kubectl compatible discovery information, optional admission chain, and versioned types. It's first consumers are k8s.io/kubernetes, k8s.io/kube-aggregator, and github.com/kubernetes-incubator/service-catalog.

Compatibility

There are NO compatibility guarantees for this repository, yet. It is in direct support of Kubernetes, so branches will track Kubernetes and be compatible with that repo. As we more cleanly separate the layers, we will review the compatibility guarantee. We have a goal to make this easier to use in the future.

Where does it come from?

apiserver is synced from https://github.com/kubernetes/kubernetes/blob/master/staging/src/k8s.io/apiserver. Code changes are made in that location, merged into k8s.io/kubernetes and later synced here.

Things you should NOT do

  1. Directly modify any files under pkg in this repo. Those are driven from k8s.io/kubernetes/staging/src/k8s.io/apiserver.
  2. Expect compatibility. This repo is changing quickly in direct support of Kubernetes and the API isn't yet stable enough for API guarantees.